• Tag Archives Transmisison
  • Server Woes

    I’ve been busy working on some upgrades for my server setup.  I currently have a Dell PowerEdge T300 under my desk that runs Plex, Minecraft, and my download box.

    Last night I made a full backup of the boot drive, which hadn’t been done in over a year. Yeah, I know, I’m lazy.  I then proceeded to upgrade from Debian 9 to Debian 10.  Took a while, but everything is running great now!

    Then I moved onto the insane project.  I have a VirtualBox machine setup running Windows 7 that handles all my downloading (it lives on my VPN).  I kinda want to get away from Windows 7, as they drop support for it at the end of the year. I figured I’d try setting it up to use Linux Lite instead, as its a tiny system and has very small overhead.

    I got the system all up, VPN was working correctly and everything.  Then came the madness of configuring the file share to the server for Transmission and Sonarr (my TV download app) to operate properly.  I could NOT get anything to cooperate properly.  For the life of me, I couldn’t get the file share to mount automatically.  On top of that, Sonarr was going to need a mountain of reconfiguring all its paths, as Windows and Linux treat things WAY different in that respect.

    After banging my head against the desk for about an hour, I’ve put Linux Lite aside.  I may come back to it, but this configuration is a bitch.  I’m now cloning the Windows 7 VM, and I’m going to attempt upgrading it to Windows 10 and see if that’s a viable option.

    I’m open to suggestions if anyone has some!